summaryrefslogtreecommitdiff
path: root/extra/python2
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python2')
-rw-r--r--extra/python2/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/extra/python2/PKGBUILD b/extra/python2/PKGBUILD
index c93cac57..519a683a 100644
--- a/extra/python2/PKGBUILD
+++ b/extra/python2/PKGBUILD
@@ -30,3 +30,16 @@ eval "$(
s/ -m test.regrtest/ -m test.regrtest -j1/
"
)"
+
+makedepends=(${makedepends[@]//xorg-server-xvfb/})
+makedepends_i686=(xorg-server-xvfb)
+
+# skip xvfb stuff on i486
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f check | \
+ sed '
+ s/xvfb-run //
+ '
+ )"
+fi