summaryrefslogtreecommitdiff
path: root/extra/python/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python/PKGBUILD')
-rw-r--r--extra/python/PKGBUILD57
1 files changed, 0 insertions, 57 deletions
diff --git a/extra/python/PKGBUILD b/extra/python/PKGBUILD
deleted file mode 100644
index a1bc36b0..00000000
--- a/extra/python/PKGBUILD
+++ /dev/null
@@ -1,57 +0,0 @@
-# tests run with -j4 per default effectively killing build slaves,
-# forcing single threaded execution of tests
-
-eval "$(
- declare -f build | \
- sed "
- s/make /make EXTRATESTOPTS='-j 1' /
- "
-)"
-
-eval "$(
- declare -f check | \
- sed "
- s/ -m test.regrtest/ -m test.regrtest -j1/
- "
-)"
-
-makedepends=(${makedepends[@]//xorg-server-xvfb/})
-makedepends_i686+=(xorg-server-xvfb)
-makedepends_pentium4=("${makedepends_i686[@]}")
-
-# skip xvfb stuff on i486
-if [ "$CARCH" = 'i486' ]; then
- eval "$(
- declare -f build | \
- sed '
- /export servernum=99/,/done/d
- s/.*make/make/
- '
- )"
- eval "$(
- declare -f check | \
- sed '
- /export servernum=99/,/done/d
- s/xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum"//
- '
- )"
-fi
-
-# ignore failing realtime scheduling test as the systemd-nspawn container
-# lacks the SYS_NICE capability (at least, I think so)
-# ERROR: test_sched_rr_get_interval (test.test_posix.PosixTester)
-# Bonus points for finding the option to ignore single tests in test_posix
-# test_gdb currently fails for unknown reasons, also not that important
-eval "$(
- declare -f check | \
- sed "
- s/-uall/-uall -x test_posix -x test_gdb \\|\\| true/g
- "
-)"
-
-# unpacking the xz archive results in LZMA errors (at least on my build slaves)
-# cannot verify GPG signature (at least on my build slaves, no .asc file)
-source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tgz")
-
-# checksums change in chaotic ways..
-sha512sums=('SKIP')