summaryrefslogtreecommitdiff
path: root/extra/nasm
diff options
context:
space:
mode:
Diffstat (limited to 'extra/nasm')
-rw-r--r--extra/nasm/PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/extra/nasm/PKGBUILD b/extra/nasm/PKGBUILD
index 36e81008..6e1fab99 100644
--- a/extra/nasm/PKGBUILD
+++ b/extra/nasm/PKGBUILD
@@ -6,11 +6,13 @@ prepare() {
patch -Np1 -i "$srcdir/0001-Remove-invalid-pure_func-qualifiers.patch"
}
+# remove ttf-liberation on i486 (X packages missing for installing the font)
+makedepends=(${makedepends[@]//ttf-liberation/})
+makedepends_i686+=(ttf-liberation)
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
# remove ttf-liberation (X packages missing for installing the font)
- makedepends=(${makedepends[@]//ttf-liberation/})
-
eval "$(
declare -f build | \
sed "