summaryrefslogtreecommitdiff
path: root/extra/nasm/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/nasm/PKGBUILD')
-rw-r--r--extra/nasm/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/extra/nasm/PKGBUILD b/extra/nasm/PKGBUILD
new file mode 100644
index 00000000..220091bd
--- /dev/null
+++ b/extra/nasm/PKGBUILD
@@ -0,0 +1,13 @@
+# see FS#60380
+source+=('0001-Remove-invalid-pure_func-qualifiers.patch')
+sha1sums+=('b853817a1dd5dc902b36ae80d11402d68e6d9a44')
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i "$srcdir/0001-Remove-invalid-pure_func-qualifiers.patch"
+}
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # remove ttf-liberation (X packages missing for installing the font)
+ makedepends=(${makedepends[@]//ttf-liberation/})
+fi