summaryrefslogtreecommitdiff
path: root/extra/mariadb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/mariadb/PKGBUILD')
-rw-r--r--extra/mariadb/PKGBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/extra/mariadb/PKGBUILD b/extra/mariadb/PKGBUILD
index 3d843259..83ea7950 100644
--- a/extra/mariadb/PKGBUILD
+++ b/extra/mariadb/PKGBUILD
@@ -1,24 +1,25 @@
# add -latomic where needed
# e.g.TARGET_LINK_LIBRARIES(mariabackup sql crc atomic)
-source+=('mariadb-10.1.32-atomic.patch')
-sha256sums+=('194e43ca5468d4f4634f45eed6aaf08865c2d351fcc500696d4dc578fe94902e')
+source+=('mariadb-10.5.10-atomic.patch')
+sha256sums+=('b235236c9a872a4921e5c6e57dbcc75e52d544ddd6ed4ac84ebd627853207b15')
eval "$(
declare -f prepare | \
sed '
- /patch -Np1.*openssl-1-1-0.patch/ a \ patch -Np1 -i "${srcdir}/mariadb-10.1.32-atomic.patch"
+ /patch -Np1.*0001-arch-specific.patch/ a \ patch -Np1 -i "${srcdir}/mariadb-10.5.10-atomic.patch"
'
)"
-# 486-specific
-if [ "${CARCH}" = "i486" ]; then
- # no java
- eval "$(
- declare -f build | \
- sed '
- s/cmake /cmake -DCONNECT_WITH_JDBC=0 /
- '
- )"
-fi
-
-# temporary checksum workaround
-sha256sums[0]='40ab19aeb8de141fdc188cf2251213c9e7351bee4d0cd29db704fae68d1068cf'
+# tests are also disabled upstream, running them manually on i486 looks ok
+#The servers were restarted 1548 times
+#Spent 5008.297 of 859 seconds executing testcases
+#
+#Completed: Failed 5/5417 tests, 99.91% were successful.
+#
+#Failing test(s): main.mysqldump main.ddl_i18n_koi8r main.ddl_i18n_utf8 main.flush_logs_not_windows perfschema.bad_option
+#
+#The log files in var/log may give you some hint of what went wrong.
+#
+#If you want to report this error, please read first the documentation
+#at http://dev.mysql.com/doc/mysql/en/mysql-test-suite.html
+#
+#962 tests were skipped, 293 by the test itself.