summaryrefslogtreecommitdiff
path: root/extra/linux-zen
diff options
context:
space:
mode:
Diffstat (limited to 'extra/linux-zen')
-rw-r--r--extra/linux-zen/PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index e9656301..314e5eb0 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -22,10 +22,12 @@ eval "$(
for ((i=0; i<${#source[@]}; i++)); do
infos=$(
printf '%s\n' "${source[${i}]}" | \
- sed -n '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
- T
- p
+ sed '
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
+ t
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
+ t
+ d
'
)
if [ -n "${infos}" ]; then