summaryrefslogtreecommitdiff
path: root/extra/linux-zen/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/linux-zen/PKGBUILD')
-rw-r--r--extra/linux-zen/PKGBUILD35
1 files changed, 28 insertions, 7 deletions
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index c659b8d1..385ba19a 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -1,9 +1,9 @@
-# upstream git revision: c8f99b5f2f2878b1988146baca636404d5d0d81d
+# upstream git revision: 31186df6fd05fa7da3267455b285e6ed5292f58f
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '08ab868847e357bff25127c5eecc3cf8acd4df6fae09fd97af6f9b82ca7d9274' ]; then
- sha256sums[${i}]='e1f5c348fda4fad09e27d1dd7524124c566a7a83dea47ea519c1e6fa91e94547'
+ if [ "${sha256sums[${i}]}" = 'ea604f8457e97764d604b3e484f372ab7b30452ef112acb23b399d39c954faaf' ]; then
+ sha256sums[${i}]='93ebf63c9e95a9b8a7ae325ce11508334ca83fd00db9677c483216a6bdef3c68'
fi
done
@@ -22,10 +22,12 @@ eval "$(
for ((i=0; i<${#source[@]}; i++)); do
infos=$(
printf '%s\n' "${source[${i}]}" | \
- sed -n '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
- T
- p
+ sed '
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
+ t
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
+ t
+ d
'
)
if [ -n "${infos}" ]; then
@@ -76,3 +78,22 @@ for ((i=0; i<${#source[@]}; i++)); do
)
fi
done
+
+# temporary (FS32#163)
+makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
+makedepends=(${makedepends[@]//python-sphinx/})
+makedepends=(${makedepends[@]//graphviz/})
+makedepends=(${makedepends[@]//imagemagick/})
+makedepends=(${makedepends[@]//texlive-latexextra/})
+eval "$(
+ declare -f build | \
+ sed '
+ s/\bhtmldocs\b//
+ '
+)"
+
+# upstream prepare() does already do the *.patch patching
+
+# avoid using zstd compression in ultra mode (exhausts virtual memory)
+source+=('core/linux/no-ultra-zstd.patch')
+sha256sums+=('d32270be5fd9c3e3ba50f3aef33f6cfcb85be0c8216f03b777287cc621fdff28')