summaryrefslogtreecommitdiff
path: root/extra/linux-pae/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/linux-pae/PKGBUILD')
-rw-r--r--extra/linux-pae/PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/extra/linux-pae/PKGBUILD b/extra/linux-pae/PKGBUILD
index 28904b14..10a3d18b 100644
--- a/extra/linux-pae/PKGBUILD
+++ b/extra/linux-pae/PKGBUILD
@@ -4,8 +4,8 @@
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-pae # Build stock -ARCH kernel
-_srcname=linux-4.17
-pkgver=4.17.10
+pkgver=4.17.12
+_srcname=linux-${pkgver}
pkgrel=1
arch=('i686')
url="https://www.kernel.org/"
@@ -14,7 +14,6 @@ makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
source=(
https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
- https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.{xz,sign}
config # the main kernel config file
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
@@ -24,14 +23,11 @@ source=(
0003-ACPI-watchdog-Prefer-iTCO_wdt-always-when-WDAT-table.patch
)
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('9faa1dd896eaea961dc6e886697c0b3301277102e5bc976b2758f9a62d3ccd13'
+sha256sums=('c098e2e4dcb64f8e3fb5cec35e872ff383edefa18532744ddf35bbba829cb5a3'
'SKIP'
- '41ad005296c7a1b5245a87881f666b3f4d7aa05a6b9409454b2e473d473c4cee'
- 'SKIP'
- '6eb872aa69991b1f700d533ec8b092be60d4c8203e1cb7da4d42d167337ec2ac'
+ '83846fdaa0560d6078aa6c88bd23b7912435d07096016d830601d903d36bada2'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
@@ -45,9 +41,6 @@ _kernelname=${pkgbase#linux}
prepare() {
cd ${_srcname}
- # add upstream patch
- patch -p1 -i ../patch-${pkgver}
-
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git