summaryrefslogtreecommitdiff
path: root/extra/linux-olpc-xo1/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/linux-olpc-xo1/PKGBUILD')
-rw-r--r--extra/linux-olpc-xo1/PKGBUILD34
1 files changed, 24 insertions, 10 deletions
diff --git a/extra/linux-olpc-xo1/PKGBUILD b/extra/linux-olpc-xo1/PKGBUILD
index 5caf5247..b4f510fe 100644
--- a/extra/linux-olpc-xo1/PKGBUILD
+++ b/extra/linux-olpc-xo1/PKGBUILD
@@ -2,11 +2,11 @@
MODEL=olpc-xo1
pkgbase=linux-${MODEL}
-pkgver='5.10.9.arch1'
+pkgver='5.17.5.arch1'
pkgrel='1'
pkgdesc='Linux for OLPC XO-1'
_srctag=v${pkgver%.*}-${pkgver##*.}
-url="https://git.archlinux.org/linux.git/log/?h=$_srctag"
+url="https://github.com/archlinux/linux/log/?h=$_srctag"
arch=(i486 i686 pentium4 x86_64)
license=(GPL2)
makedepends=(
@@ -17,7 +17,7 @@ makedepends=(
options=('!strip')
_srcname=archlinux-linux
source=(
- "$_srcname::git+https://git.archlinux.org/linux.git?signed#tag=$_srctag"
+ "$_srcname::git+https://github.com/archlinux/linux?signed#tag=$_srctag"
config.${MODEL} # the main kernel config file
)
validpgpkeys=(
@@ -25,8 +25,8 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
)
-sha256sums=('7c7b1c643546a9d5703de4569d253c619f2532b4ac871e5cd148e0ed25620648'
- '18730a94777487843be91aff97ca7553e6a666219c810fc570a920f877877c1d')
+sha256sums=('01c9517e942fd146fee8d7ad6a44b02f849f0bc3ebf605665e262a271cae3f12'
+ 'bc2eb14af084433738f8cc8717778c146dea9629ddf60703071835ea45cecb19')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -51,7 +51,10 @@ prepare() {
echo "Setting config..."
cp ../config.${MODEL} .config
- make olddefconfig
+ # make olddefconfig
+
+ # rewrite configuration
+ yes "" | make config >/dev/null
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
@@ -193,10 +196,12 @@ done
for ((i=0; i<${#source[@]}; i++)); do
infos=$(
printf '%s\n' "${source[${i}]}" | \
- sed -n '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
- T
- p
+ sed '
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
+ t
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
+ t
+ d
'
)
if [ -n "${infos}" ]; then
@@ -247,3 +252,12 @@ for ((i=0; i<${#source[@]}; i++)); do
)
fi
done
+
+# avoid using zstd compression in ultra mode (exhausts virtual memory)
+source+=('core/linux/no-ultra-zstd.patch')
+sha256sums+=('d32270be5fd9c3e3ba50f3aef33f6cfcb85be0c8216f03b777287cc621fdff28')
+
+# https://bbs.archlinux32.org/viewtopic.php?pid=9109#p9109
+# avoid "sleepy" VIA C7 CPUs (and possibly others)
+source+=('core/linux/acpi-c3.patch')
+sha256sums+=('fc44aaf0b68abc9502fd4e0f73345c53b756566b532005466b106bacc9f9bc9c')