summaryrefslogtreecommitdiff
path: root/extra/libreoffice-still
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libreoffice-still')
-rw-r--r--extra/libreoffice-still/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/extra/libreoffice-still/PKGBUILD b/extra/libreoffice-still/PKGBUILD
index 0f0d9e65..66998621 100644
--- a/extra/libreoffice-still/PKGBUILD
+++ b/extra/libreoffice-still/PKGBUILD
@@ -7,3 +7,26 @@ eval "$(
s|--enable-ext-nlpsolver|--disable-ext-nlpsolver|
'
)"
+
+# no coin-ormp on i486 (for now, suitesparse has atomic issues)
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//coin-or-mp/})
+fi
+
+# ignore mariadb on i486 (for now)
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//mariadb-libs/})
+fi
+
+# Java currently broken on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//java-environment=11/})
+ makedepends=(${makedepends[@]//ant/})
+ makedepends=(${makedepends[@]//junit/})
+ makedepends=(${makedepends[@]//beanshell/})
+fi
+
+# no KDE/Plasma on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//plasma-framework/})
+fi