summaryrefslogtreecommitdiff
path: root/extra/libotf/libotf-0.9.16-pkgconf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libotf/libotf-0.9.16-pkgconf.patch')
-rw-r--r--extra/libotf/libotf-0.9.16-pkgconf.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/extra/libotf/libotf-0.9.16-pkgconf.patch b/extra/libotf/libotf-0.9.16-pkgconf.patch
new file mode 100644
index 00000000..36115bb3
--- /dev/null
+++ b/extra/libotf/libotf-0.9.16-pkgconf.patch
@@ -0,0 +1,31 @@
+diff -rauN libotf-0.9.16/configure.ac libotf-0.9.16-pkgconf-patch/configure.ac
+--- libotf-0.9.16/configure.ac 2018-01-24 00:01:37.000000000 +0100
++++ libotf-0.9.16-pkgconf-patch/configure.ac 2019-11-26 20:06:12.782289945 +0100
+@@ -50,13 +50,24 @@
+
+ # Check for Freetype2 usability.
+ AC_CHECK_PROG(HAVE_FREETYPE_CONFIG, freetype-config, yes)
+-if test "x$HAVE_FREETYPE_CONFIG" = "xyes"; then
+- FREETYPE_INC=`freetype-config --cflags`
++AC_CHECK_PROG(HAVE_PKGCONF, pkgconf, yes)
++if test "x$HAVE_FREETYPE_CONFIG" = "xyes" -o "x$HAVE_PKGCONF" = "xyes"; then
++ if test "x$HAVE_FREETYPE_CONFIG" = "xyes"; then
++ FREETYPE_INC=`freetype-config --cflags`
++ fi
++ if test "x$HAVE_PKGCONF" = "xyes"; then
++ FREETYPE_INC=`pkgconf --cflags freetype2`
++ fi
+ CPPFLAGS="$CPPFLAGS $FREETYPE_INC"
+ AC_CHECK_HEADER(ft2build.h, HAVE_FREETYPE=yes,
+ HAVE_FREETYPE=no CPPFLAGS=$save_CPPFLAGS)
+ if test "x$HAVE_FREETYPE" = "xyes" ; then
+- FREETYPE_LD_FLAGS=`freetype-config --libs`;
++ if test "x$HAVE_FREETYPE_CONFIG" = "xyes"; then
++ FREETYPE_LD_FLAGS=`freetype-config --libs`;
++ fi
++ if test "x$HAVE_PKGCONF" = "xyes"; then
++ FREETYPE_LD_FLAGS=`pkgconf --libs freetype2`;
++ fi
+ LIBS="$LIBS $FREETYPE_LD_FLAGS"
+ AC_CHECK_LIB(freetype, FT_Init_FreeType, HAVE_FREETYPE=yes,
+ HAVE_FREETYPE=no)