summaryrefslogtreecommitdiff
path: root/extra/grantlee/grantlee-c++11.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extra/grantlee/grantlee-c++11.patch')
-rw-r--r--extra/grantlee/grantlee-c++11.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/extra/grantlee/grantlee-c++11.patch b/extra/grantlee/grantlee-c++11.patch
new file mode 100644
index 00000000..d049d6c9
--- /dev/null
+++ b/extra/grantlee/grantlee-c++11.patch
@@ -0,0 +1,24 @@
+From 3a5fc7662da3261be6496611900c095844e56ab1 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Sat, 20 Jul 2019 17:35:30 +0200
+Subject: [PATCH] Fix compile with newer Qt/cmake combination
+
+Without this i get huge errors about Qt needing C++11 support
+---
+ CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6d51110..0859788 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -11,6 +11,9 @@ endif()
+
+ project(Grantlee)
+
++set (CMAKE_CXX_STANDARD 11)
++set (CMAKE_CXX_EXTENSIONS OFF)
++
+ # Workaround for http://public.kitware.com/Bug/view.php?id=12301
+ if (MINGW)
+ if(NOT CMAKE_BUILD_TYPE)