summaryrefslogtreecommitdiff
path: root/extra/grantlee/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/grantlee/PKGBUILD')
-rw-r--r--extra/grantlee/PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/extra/grantlee/PKGBUILD b/extra/grantlee/PKGBUILD
new file mode 100644
index 00000000..70e81152
--- /dev/null
+++ b/extra/grantlee/PKGBUILD
@@ -0,0 +1,15 @@
+# forward port from see FS#63552
+
+source+=(grantlee-c++11.patch grantlee-qt-5.13.patch)
+sha256sums+=('a14257e61489ee46c9236cc21af06e0eee5084c1563992d5a470153c7f318999'
+ '60226562926c881cc617f236936d611a85e841865095e215f0f470d1eb945b77')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ 3 a \
+ cd $pkgname-$pkgver \
+ patch -p1 -i ../grantlee-c++11.patch # Fix build with new gcc/Qt combinations \
+ patch -p1 -i ../grantlee-qt-5.13.patch # Fix build with Qt 5.13
+ '
+)"