summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD14
-rw-r--r--extra/firefox/mozconfig.patch12
2 files changed, 18 insertions, 8 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index a76ae2ac..c93b5028 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -2,7 +2,7 @@
# don't compile with clang, use gcc toolchain (clang has issues on IA32)
# TODO: document the rest..
source+=('mozconfig.patch')
-sha256sums+=('0dcc5435b83e39f5725850818494617f2098d7535619ee169237d450489d6260')
+sha256sums+=('f0de0124f841ce219a6816383cf500b4cc157e34df71d4d9fe7bd7e23047440c')
eval "$(
declare -f build | \
sed '
@@ -96,7 +96,7 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('eee6f990abf166da5dba7137ccf8e8bf4aac79e1c3db1cfeec67f797609b3e59')
+sha256sums+=('d07e283d5c784bb44dcd0ad3f6b82f19cac562451ce07033e8dde50bf8c75d76')
eval "$(
declare -f prepare | \
sed '
@@ -104,6 +104,16 @@ eval "$(
'
)"
+# gcc and cross PGO are not best friends, disable PGO
+eval "$(
+ declare -f build | \
+ sed '
+ /--enable-profile-generate=cross/d
+ /--with-pgo-profile-path=/d
+ /--with-pgo-jarlog=/d
+ '
+)"
+
# readelf: Error: Unable to seek to 0x801db328 for section headers
source+=('avoid-libxul-OOM-python-check.patch')
sha256sums+=('5a3e038a57c4576dcb88766d41cbfda5ad109d5cfe41d2000f7ba25563bf00f2')
diff --git a/extra/firefox/mozconfig.patch b/extra/firefox/mozconfig.patch
index 2363102f..97318c3f 100644
--- a/extra/firefox/mozconfig.patch
+++ b/extra/firefox/mozconfig.patch
@@ -1,6 +1,6 @@
diff -rauN a/mozconfig b/mozconfig
---- a/mozconfig 2019-10-25 16:05:08.760547591 +0200
-+++ b/mozconfig 2019-10-25 16:03:07.125511113 +0200
+--- a/mozconfig 2019-10-25 16:52:15.320214766 +0200
++++ b/mozconfig 2019-10-25 16:52:51.400721588 +0200
@@ -5,11 +5,12 @@
ac_add_options --enable-hardening
ac_add_options --enable-optimize
@@ -19,10 +19,10 @@ diff -rauN a/mozconfig b/mozconfig
# Branding
ac_add_options --enable-official-branding
-@@ -38,6 +39,3 @@
+@@ -38,3 +39,6 @@
ac_add_options --disable-gconf
ac_add_options --disable-updater
ac_add_options --disable-tests
--
--# disable PGO
--ac_add_options --disable-cross-pgo
++
++# disable PGO
++ac_add_options --disable-cross-pgo