summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD11
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch19
2 files changed, 30 insertions, 0 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 8ee63332..46db9912 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -87,3 +87,14 @@ eval "$(
2 a export MOZ_MAKE_FLAGS=-j1
'
)"
+
+# test failure in rust code (complaining about network functions) when PGO is used,
+# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
+source+=('rust-static-disable-network-test-on-static-libraries.patch')
+sha256sums+=('3502138d1b43d734743137b97ea220d56338e7ee15d6159b030489637e274fc0')
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -p1 -i "$srcdir/rust-static-disable-network-test-on-static-libraries.patch"
+ '
+)"
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
new file mode 100644
index 00000000..84dcc1d3
--- /dev/null
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -0,0 +1,19 @@
+diff -rauN a/config/makefiles/rust.mk b/config/makefiles/rust.mk
+--- a/config/makefiles/rust.mk 2019-09-21 12:17:00.399732877 +0200
++++ b/config/makefiles/rust.mk 2019-09-21 12:18:04.531378287 +0200
+@@ -244,6 +244,7 @@
+ # When we are building in --enable-release mode; we add an additional check to confirm
+ # that we are not importing any networking-related functions in rust code. This reduces
+ # the chance of proxy bypasses originating from rust code.
++ifndef MOZ_PROFILE_GENERATE
+ ifndef DEVELOPER_OPTIONS
+ ifndef MOZ_DEBUG_RUST
+ ifeq ($(OS_ARCH), Linux)
+@@ -251,6 +252,7 @@
+ endif
+ endif
+ endif
++endif
+
+ force-cargo-library-check:
+ $(call CARGO_CHECK) --lib $(cargo_target_flag) $(rust_features_flag)