summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD11
-rw-r--r--extra/firefox/mozconfig.patch16
2 files changed, 17 insertions, 10 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 549b51cc..34212cde 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -1,5 +1,8 @@
+# disable LTO as it has little benefit and uses too many resources
+# don't compile with clang, use gcc toolchain (clang has issues on IA32)
+# TODO: document the rest..
source+=('mozconfig.patch')
-sha256sums+=('4f94ab5e8442a032edfd457ac5d4a2d237db0093906c97e82436af56e0500b52')
+sha256sums+=('62eb5b45f7eaa1879f9c9b0df92ed8de869a25b05ef6cd71c699cb44cee7cc97')
eval "$(
declare -f build | \
sed '
@@ -12,6 +15,9 @@ eval "$(
$ i patch -p1 -i "$srcdir/mozconfig.patch"
'
)"
+
+# use locally cached version of firefox sources
+# TODO: think about how to put this into helper functions
for ((i=0; i<${#source[@]}; i++)); do
infos=$(
printf '%s\n' "${source[${i}]}" | \
@@ -72,11 +78,10 @@ done
# from VoidLinux, avoid excessive debug symbols in rust leading
# to out-of-memory situations
-
eval "$(
declare -f build | \
sed '
- 5 a sed -i "s/debug_info = '\''2'\''/debug_info = '\''1'\''/" build/moz.configure/toolchain.configure
+ 5 a sed -i "s/debug_info = '\''2'\''/debug_info = '\''0'\''/" build/moz.configure/toolchain.configure
'
)"
diff --git a/extra/firefox/mozconfig.patch b/extra/firefox/mozconfig.patch
index 8d1f66c5..9e5d85de 100644
--- a/extra/firefox/mozconfig.patch
+++ b/extra/firefox/mozconfig.patch
@@ -1,12 +1,12 @@
---- a/.mozconfig 2019-01-21 09:21:00.221010326 +0100
-+++ b/.mozconfig 2019-01-21 09:22:02.477911431 +0100
-@@ -5,12 +7,11 @@
+diff -rauN a/.mozconfig b/.mozconfig
+--- a/.mozconfig 2019-10-24 17:22:00.620041647 +0200
++++ b/.mozconfig 2019-10-24 17:27:57.878744247 +0200
+@@ -5,11 +5,14 @@
+ ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
--ac_add_options --enable-lto
--export MOZ_PGO=1
--export CC=clang
--export CXX=clang++
+-export CC='clang --target=x86_64-unknown-linux-gnu'
+-export CXX='clang++ --target=x86_64-unknown-linux-gnu'
-export AR=llvm-ar
-export NM=llvm-nm
-export RANLIB=llvm-ranlib
@@ -16,6 +16,8 @@
+export AR=gcc-ar
+export NM=gcc-nm
+export RANLIB=gcc-ranlib
++
+++ac_add_options --disable-lto
# Branding
ac_add_options --enable-official-branding