summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD17
-rw-r--r--extra/firefox/avoid-libxul-OOM-python-check.patch8
-rw-r--r--extra/firefox/mozconfig.patch12
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch8
4 files changed, 25 insertions, 20 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 11d9d040..2fb535bf 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -2,7 +2,7 @@
# don't compile with clang, use gcc toolchain (clang has issues on IA32)
# TODO: document the rest..
source+=('mozconfig.patch')
-sha256sums+=('f0de0124f841ce219a6816383cf500b4cc157e34df71d4d9fe7bd7e23047440c')
+sha256sums+=('708605f390994587277d8357e8452a71fcbfab97394df9678b1b646539e4ce20')
eval "$(
declare -f build | \
sed '
@@ -16,6 +16,17 @@ eval "$(
'
)"
+# do not build a first firefox, run it in headless X just to produce
+# some profiling data and build it again. the penalty of using a 32-bit
+# build is high enough, so optimizing based on profiling data will not
+# be that helpfull IMHO.
+eval "$(
+ declare -f build | \
+ sed '
+ /.\/mach package/,/.\/mach build/d
+ '
+)"
+
# use locally cached version of firefox sources
# TODO: think about how to put this into helper functions
for ((i=0; i<${#source[@]}; i++)); do
@@ -96,7 +107,7 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('4da71f6614dce71db8e9ec2d317514aae90838c2c65620d435f0df06b45b578b')
+sha256sums+=('7ef04324ca732df50fc33f21d8e7027c43e3c7c3a51d2332dd44853910315a67')
eval "$(
declare -f prepare | \
sed '
@@ -116,7 +127,7 @@ eval "$(
# readelf: Error: Unable to seek to 0x801db328 for section headers
source+=('avoid-libxul-OOM-python-check.patch')
-sha256sums+=('5a3e038a57c4576dcb88766d41cbfda5ad109d5cfe41d2000f7ba25563bf00f2')
+sha256sums+=('6395b7e349963c9a689929b44525159328954af156ef0b9a42182e7e16baa8ba')
eval "$(
declare -f prepare | \
sed '
diff --git a/extra/firefox/avoid-libxul-OOM-python-check.patch b/extra/firefox/avoid-libxul-OOM-python-check.patch
index 9ab81bb7..89fa3f38 100644
--- a/extra/firefox/avoid-libxul-OOM-python-check.patch
+++ b/extra/firefox/avoid-libxul-OOM-python-check.patch
@@ -1,10 +1,10 @@
diff -rauN a/config/rules.mk b/config/rules.mk
---- a/config/rules.mk 2019-10-25 11:08:20.757231756 +0200
-+++ b/config/rules.mk 2019-10-25 11:11:04.972821611 +0200
-@@ -663,7 +663,7 @@
+--- a/config/rules.mk 2020-04-04 12:24:34.837582901 +0200
++++ b/config/rules.mk 2020-04-04 12:26:14.227584517 +0200
+@@ -608,7 +608,7 @@
$(RM) $@
endif
- $(MKSHLIB) $($@_$(OBJS_VAR_SUFFIX)) $(RESFILE) $(LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
+ $(MKSHLIB) $($@_OBJS) $(RESFILE) $(LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
- $(call py_action,check_binary,--target $@)
+# $(call py_action,check_binary,--target $@)
diff --git a/extra/firefox/mozconfig.patch b/extra/firefox/mozconfig.patch
index 97318c3f..b179e883 100644
--- a/extra/firefox/mozconfig.patch
+++ b/extra/firefox/mozconfig.patch
@@ -1,6 +1,6 @@
diff -rauN a/mozconfig b/mozconfig
---- a/mozconfig 2019-10-25 16:52:15.320214766 +0200
-+++ b/mozconfig 2019-10-25 16:52:51.400721588 +0200
+--- a/mozconfig 2020-04-04 12:27:32.340912278 +0200
++++ b/mozconfig 2020-04-04 12:28:33.890907786 +0200
@@ -5,11 +5,12 @@
ac_add_options --enable-hardening
ac_add_options --enable-optimize
@@ -19,10 +19,4 @@ diff -rauN a/mozconfig b/mozconfig
# Branding
ac_add_options --enable-official-branding
-@@ -38,3 +39,6 @@
- ac_add_options --disable-gconf
- ac_add_options --disable-updater
- ac_add_options --disable-tests
-+
-+# disable PGO
-+ac_add_options --disable-cross-pgo
+
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index f5e0f6a0..239a20dc 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,7 +1,7 @@
-diff -rauN firefox-72.0.1/config/makefiles/rust.mk firefox-72.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk
---- firefox-72.0.1/config/makefiles/rust.mk 2020-01-08 02:23:30.000000000 +0100
-+++ firefox-72.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk 2020-01-10 12:17:40.172666172 +0100
-@@ -292,17 +292,17 @@
+diff -rauN firefox-74.0.1/config/makefiles/rust.mk firefox-74.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk
+--- firefox-74.0.1/config/makefiles/rust.mk 2020-04-03 13:10:23.000000000 +0200
++++ firefox-74.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk 2020-04-04 12:31:27.804227950 +0200
+@@ -283,17 +283,17 @@
# the chance of proxy bypasses originating from rust code.
# The check only works when rust code is built with -Clto.
# Enabling sancov or TSan also causes this to fail.