summaryrefslogtreecommitdiff
path: root/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox/rust-static-disable-network-test-on-static-libraries.patch')
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index 9e4baffa..32dabb4c 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,20 +1,20 @@
diff -rauN a/config/makefiles/rust.mk b/config/makefiles/rust.mk
---- a/config/makefiles/rust.mk 2019-09-17 19:02:50.000000000 +0200
-+++ b/config/makefiles/rust.mk 2019-09-21 15:24:51.554451253 +0200
-@@ -244,13 +244,13 @@
- # When we are building in --enable-release mode; we add an additional check to confirm
+--- a/config/makefiles/rust.mk 2019-10-25 10:57:20.061421120 +0200
++++ b/config/makefiles/rust.mk 2019-10-25 11:06:30.065708309 +0200
+@@ -252,13 +252,13 @@
# that we are not importing any networking-related functions in rust code. This reduces
# the chance of proxy bypasses originating from rust code.
--ifndef DEVELOPER_OPTIONS
--ifndef MOZ_DEBUG_RUST
+ # The check only works when rust code is built with -Clto.
+-ifndef MOZ_PROFILE_GENERATE
-ifeq ($(OS_ARCH), Linux)
+-ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
- $(call py_action,check_binary,--target --networking $@)
-endif
-endif
-endif
-+#ifndef DEVELOPER_OPTIONS
-+#ifndef MOZ_DEBUG_RUST
++#ifndef MOZ_PROFILE_GENERATE
+#ifeq ($(OS_ARCH), Linux)
++#ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
+# $(call py_action,check_binary,--target --networking $@)
+#endif
+#endif