summaryrefslogtreecommitdiff
path: root/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox/rust-static-disable-network-test-on-static-libraries.patch')
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch21
1 files changed, 8 insertions, 13 deletions
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index 239a20dc..2ce3ce16 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,28 +1,23 @@
-diff -rauN firefox-74.0.1/config/makefiles/rust.mk firefox-74.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk
---- firefox-74.0.1/config/makefiles/rust.mk 2020-04-03 13:10:23.000000000 +0200
-+++ firefox-74.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk 2020-04-04 12:31:27.804227950 +0200
-@@ -283,17 +283,17 @@
+--- firefox-77.0.1/config/makefiles/rust.mk 2020-06-03 03:04:50.000000000 +0200
++++ firefox-77.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk 2020-06-04 16:37:14.534723243 +0200
+@@ -299,15 +299,15 @@
# the chance of proxy bypasses originating from rust code.
# The check only works when rust code is built with -Clto.
- # Enabling sancov or TSan also causes this to fail.
+ # Sanitizers and sancov also fail because compiler-rt hooks network functions.
-ifndef MOZ_PROFILE_GENERATE
--ifndef MOZ_TSAN
-ifeq ($(OS_ARCH), Linux)
--ifeq (,$(rustflags_sancov))
+-ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
-ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
-- $(call py_action,check_binary,--target --networking $@)
--endif
+- $(call py3_action,check_binary,--target --networking $@)
-endif
-endif
-endif
-endif
+#ifndef MOZ_PROFILE_GENERATE
-+#ifndef MOZ_TSAN
+#ifeq ($(OS_ARCH), Linux)
-+#ifeq (,$(rustflags_sancov))
++#ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
+#ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
-+# $(call py_action,check_binary,--target --networking $@)
-+#endif
++# $(call py3_action,check_binary,--target --networking $@)
+#endif
+#endif
+#endif