summaryrefslogtreecommitdiff
path: root/extra/firefox/avoid-libxul-OOM-python-check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox/avoid-libxul-OOM-python-check.patch')
-rw-r--r--extra/firefox/avoid-libxul-OOM-python-check.patch29
1 files changed, 23 insertions, 6 deletions
diff --git a/extra/firefox/avoid-libxul-OOM-python-check.patch b/extra/firefox/avoid-libxul-OOM-python-check.patch
index 89fa3f38..4aaf550c 100644
--- a/extra/firefox/avoid-libxul-OOM-python-check.patch
+++ b/extra/firefox/avoid-libxul-OOM-python-check.patch
@@ -1,12 +1,29 @@
-diff -rauN a/config/rules.mk b/config/rules.mk
---- a/config/rules.mk 2020-04-04 12:24:34.837582901 +0200
-+++ b/config/rules.mk 2020-04-04 12:26:14.227584517 +0200
-@@ -608,7 +608,7 @@
+--- firefox-77.0.1/config/rules.mk 2020-06-03 03:04:50.000000000 +0200
++++ firefox-77.0.1-avoid-libxul-OOM-python-check-patch/config/rules.mk 2020-06-04 16:43:06.709092454 +0200
+@@ -474,7 +474,7 @@
+ endif # MSVC with manifest tool
+ else # !WINNT || GNU_CC
+ $(call EXPAND_CC_OR_CXX,$@) -o $@ $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) $($(notdir $@)_OBJS) $(RESFILE) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
+- $(call py3_action,check_binary,--target $@)
++# $(call py3_action,check_binary,--target $@)
+ endif # WINNT && !GNU_CC
+
+ ifdef ENABLE_STRIP
+@@ -530,7 +530,7 @@
+ endif # MSVC with manifest tool
+ else
+ $(call EXPAND_CC_OR_CXX,$@) $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) -o $@ $($@_OBJS) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
+- $(call py3_action,check_binary,--target $@)
++# $(call py3_action,check_binary,--target $@)
+ endif # WINNT && !GNU_CC
+
+ ifdef ENABLE_STRIP
+@@ -610,7 +610,7 @@
$(RM) $@
endif
$(MKSHLIB) $($@_OBJS) $(RESFILE) $(LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
-- $(call py_action,check_binary,--target $@)
-+# $(call py_action,check_binary,--target $@)
+- $(call py3_action,check_binary,--target $@)
++# $(call py3_action,check_binary,--target $@)
ifeq (_WINNT,$(GNU_CC)_$(OS_ARCH))
ifdef MSMANIFEST_TOOL