summaryrefslogtreecommitdiff
path: root/extra/firefox/avoid-libxul-OOM-python-check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox/avoid-libxul-OOM-python-check.patch')
-rw-r--r--extra/firefox/avoid-libxul-OOM-python-check.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/extra/firefox/avoid-libxul-OOM-python-check.patch b/extra/firefox/avoid-libxul-OOM-python-check.patch
new file mode 100644
index 00000000..d9db28ab
--- /dev/null
+++ b/extra/firefox/avoid-libxul-OOM-python-check.patch
@@ -0,0 +1,12 @@
+diff -rauN a/config/rules.mk b/config/rules.mk
+--- a/config/rules.mk 2019-09-21 19:14:10.531026841 +0200
++++ b/config/rules.mk 2019-09-21 19:15:08.752873377 +0200
+@@ -660,7 +660,7 @@
+ $(RM) $@
+ endif
+ $(MKSHLIB) $($@_$(OBJS_VAR_SUFFIX)) $(RESFILE) $(LDFLAGS) $(STATIC_LIBS) $(RUST_STATIC_LIB) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
+- $(call py_action,check_binary,--target $@)
++# $(call py_action,check_binary,--target $@)
+
+ ifeq (_WINNT,$(GNU_CC)_$(OS_ARCH))
+ ifdef MSMANIFEST_TOOL