summaryrefslogtreecommitdiff
path: root/extra/firefox/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox/PKGBUILD')
-rw-r--r--extra/firefox/PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 81c26086..f886c6af 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -1,12 +1,15 @@
+source+=('mozconfig.patch')
+sha256sums+=('a9f99789801106d82ec48839d25c0b3358f6641a55d20b4d686f10197b14322d')
eval "$(
declare -f build | \
sed '
- /cd mozilla-unified/a sed -i "s/\\(cargo_rustc_flags += -C lto\\)/#\\1/" config/rules.mk
+ 2 a export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"
+ 2 a export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
'
declare -f prepare | \
sed '
$ i export MOZ_SOURCE_CHANGESET="DEVEDITION_${pkgver//./_}_RELEASE"
- $ i LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ $ i patch -p1 -i "$srcdir/mozconfig.patch"
'
)"
for ((i=0; i<${#source[@]}; i++)); do