summaryrefslogtreecommitdiff
path: root/extra/firefox/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox/PKGBUILD')
-rw-r--r--extra/firefox/PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 549b51cc..34212cde 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -1,5 +1,8 @@
+# disable LTO as it has little benefit and uses too many resources
+# don't compile with clang, use gcc toolchain (clang has issues on IA32)
+# TODO: document the rest..
source+=('mozconfig.patch')
-sha256sums+=('4f94ab5e8442a032edfd457ac5d4a2d237db0093906c97e82436af56e0500b52')
+sha256sums+=('62eb5b45f7eaa1879f9c9b0df92ed8de869a25b05ef6cd71c699cb44cee7cc97')
eval "$(
declare -f build | \
sed '
@@ -12,6 +15,9 @@ eval "$(
$ i patch -p1 -i "$srcdir/mozconfig.patch"
'
)"
+
+# use locally cached version of firefox sources
+# TODO: think about how to put this into helper functions
for ((i=0; i<${#source[@]}; i++)); do
infos=$(
printf '%s\n' "${source[${i}]}" | \
@@ -72,11 +78,10 @@ done
# from VoidLinux, avoid excessive debug symbols in rust leading
# to out-of-memory situations
-
eval "$(
declare -f build | \
sed '
- 5 a sed -i "s/debug_info = '\''2'\''/debug_info = '\''1'\''/" build/moz.configure/toolchain.configure
+ 5 a sed -i "s/debug_info = '\''2'\''/debug_info = '\''0'\''/" build/moz.configure/toolchain.configure
'
)"