summaryrefslogtreecommitdiff
path: root/extra/firefox/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox/PKGBUILD')
-rw-r--r--extra/firefox/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 6eaccdb4..31c7632d 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -174,3 +174,12 @@ eval "$(
/msg2 "Profiling instrumented browser..."/,/.\/mach build/d
'
)"
+
+# libvpx has some hard-coded compiler flags for MMX, SSE, SSE2, use the correct one
+# per CARCH (75.0 uses an intrisic _mm_empty now, which required the corresponding
+# architecture flag to be preset - before it was merely embedding some assembly
+# code with EMMS
+if [ "${CARCH}" = "i686" ]; then
+ CFLAGS="$CFLAGS -mmmx"
+ CXXFLAGS="$CXXFLAGS -mmmx"
+fi