summaryrefslogtreecommitdiff
path: root/extra/ffmpeg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/ffmpeg/PKGBUILD')
-rw-r--r--extra/ffmpeg/PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/extra/ffmpeg/PKGBUILD b/extra/ffmpeg/PKGBUILD
index 7de304f8..d266facb 100644
--- a/extra/ffmpeg/PKGBUILD
+++ b/extra/ffmpeg/PKGBUILD
@@ -1,10 +1,13 @@
# disable LTO (breaks with too few registers in error: 'asm' operand has impossible constraints
+# also disable mfx - libmfx does not compile
eval "$(
declare -f build | \
sed '
s/--enable-lto/--disable-lto/
+ s/--enable-mfx/--disable-mfx/
'
)"
+depends=("${depends[@]//libmfx/}")
# no vamf for non-pentium4
if [ "$CARCH" == 'i686' ] || [ "$CARCH" == 'i486' ]; then