summaryrefslogtreecommitdiff
path: root/extra/colord
diff options
context:
space:
mode:
Diffstat (limited to 'extra/colord')
-rw-r--r--extra/colord/PKGBUILD30
1 files changed, 2 insertions, 28 deletions
diff --git a/extra/colord/PKGBUILD b/extra/colord/PKGBUILD
index 35e2cce2..b34b2c2a 100644
--- a/extra/colord/PKGBUILD
+++ b/extra/colord/PKGBUILD
@@ -1,16 +1,3 @@
-# no Vala on i486
-makedepends=(${makedepends[@]//vala/})
-makedepends_i686+=(vala)
-makedepends_pentium4=("${makedepends_i686[@]}")
-if [ "$CARCH" = 'i486' ]; then
- eval "$(
- declare -f build | \
- sed '
- s@ -D vapi=true@ -D vapi=false@
- '
- )"
-fi
-
# This is a dirty hack to prevent differing float precisions.
# See https://bugs.freedesktop.org/show_bug.cgi?id=102676
eval "$(
@@ -23,21 +10,8 @@ eval "$(
'
)"
-# no polkit, no js78, no rust, no potatoes on i486
+# no polkit, no js78, no rust, use polkit-duktape on i486
if [ "$CARCH" = 'i486' ]; then
depends=(${depends[@]//polkit/})
- eval "$(
- declare -f build | \
- sed '
- s/arch-meson/arch-meson -D daemon=false/
- '
- )"
- eval "$(
- declare -f package_colord | \
- sed '
- /libcolord_sensor_sane.so/d
- '
- )"
- # tests don't work on i486 (most likely because we disabled the daemon)
- unset check
+ depends+=(polkit-duktape)
fi