summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/linux/PKGBUILD10
-rw-r--r--core/linux/config.i4867
-rw-r--r--core/linux/config.i6867
-rw-r--r--core/linux/config.pentium47
4 files changed, 20 insertions, 11 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index e05d8a3a..04b914f4 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -1,14 +1,14 @@
-# upstream git revision: 14d23c00831ec7264a3247ba94bb40d0eda09975
+# upstream git revision: 48cbbca48bfe66fe382921fba1974a8ed8ba941b
source_pentium4=('config.pentium4')
source_i686=('config.i686')
source_i486=('config.i486')
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = 'e749cd85d37d4d70099b0a7f54e852b039ae07c14e4ab8be299c64edae5d4ba4' ]; then
- sha256sums_pentium4=('e3541f4f2b81dbdf8677d8bd5304bbdc48417d230bb70c973ac28bda4c7301c7')
- sha256sums_i686=('e3541f4f2b81dbdf8677d8bd5304bbdc48417d230bb70c973ac28bda4c7301c7')
- sha256sums_i486=('ff1e3af5b8065f0ed144efc8358a1875b7406addf1480448248770d3433e5344')
+ if [ "${sha256sums[${i}]}" = '10ee7800902b1d82f9c184b367c9d904f4dc48f6d9ce3277327e825d7ab690d1' ]; then
+ sha256sums_pentium4=('4892f282722393b0987a0c27455512e2b184b6c0e80c4e0bb30128d6eadfd099')
+ sha256sums_i686=('4892f282722393b0987a0c27455512e2b184b6c0e80c4e0bb30128d6eadfd099')
+ sha256sums_i486=('c676bf0236d952876c2d23f68211a15dd7f25dd0931c4e527fa60fa509a4b4d3')
fi
done
diff --git a/core/linux/config.i486 b/core/linux/config.i486
index aaa9707b..69f4a9df 100644
--- a/core/linux/config.i486
+++ b/core/linux/config.i486
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.3.10-arch1 Kernel Configuration
+# Linux/x86 5.3.12-arch1 Kernel Configuration
#
#
@@ -438,6 +438,9 @@ CONFIG_ARCH_USES_PG_UNCACHED=y
CONFIG_ARCH_RANDOM=y
CONFIG_X86_SMAP=y
CONFIG_X86_INTEL_UMIP=y
+# CONFIG_X86_INTEL_TSX_MODE_OFF is not set
+# CONFIG_X86_INTEL_TSX_MODE_ON is not set
+CONFIG_X86_INTEL_TSX_MODE_AUTO=y
CONFIG_EFI=y
CONFIG_EFI_STUB=y
CONFIG_SECCOMP=y
@@ -9759,7 +9762,7 @@ CONFIG_GCC_PLUGIN_STRUCTLEAK=y
CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF_ALL=y
# CONFIG_GCC_PLUGIN_STRUCTLEAK_VERBOSE is not set
# CONFIG_GCC_PLUGIN_STACKLEAK is not set
-# CONFIG_INIT_ON_ALLOC_DEFAULT_ON is not set
+CONFIG_INIT_ON_ALLOC_DEFAULT_ON=y
# CONFIG_INIT_ON_FREE_DEFAULT_ON is not set
# end of Memory initialization
# end of Kernel hardening options
diff --git a/core/linux/config.i686 b/core/linux/config.i686
index 6df8c73f..3c9e65ea 100644
--- a/core/linux/config.i686
+++ b/core/linux/config.i686
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.3.10-arch1 Kernel Configuration
+# Linux/x86 5.3.12-arch1 Kernel Configuration
#
#
@@ -441,6 +441,9 @@ CONFIG_ARCH_USES_PG_UNCACHED=y
CONFIG_ARCH_RANDOM=y
CONFIG_X86_SMAP=y
CONFIG_X86_INTEL_UMIP=y
+# CONFIG_X86_INTEL_TSX_MODE_OFF is not set
+# CONFIG_X86_INTEL_TSX_MODE_ON is not set
+CONFIG_X86_INTEL_TSX_MODE_AUTO=y
CONFIG_EFI=y
CONFIG_EFI_STUB=y
CONFIG_SECCOMP=y
@@ -9837,7 +9840,7 @@ CONFIG_GCC_PLUGIN_STRUCTLEAK=y
CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF_ALL=y
# CONFIG_GCC_PLUGIN_STRUCTLEAK_VERBOSE is not set
# CONFIG_GCC_PLUGIN_STACKLEAK is not set
-# CONFIG_INIT_ON_ALLOC_DEFAULT_ON is not set
+CONFIG_INIT_ON_ALLOC_DEFAULT_ON=y
# CONFIG_INIT_ON_FREE_DEFAULT_ON is not set
# end of Memory initialization
# end of Kernel hardening options
diff --git a/core/linux/config.pentium4 b/core/linux/config.pentium4
index 6df8c73f..3c9e65ea 100644
--- a/core/linux/config.pentium4
+++ b/core/linux/config.pentium4
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.3.10-arch1 Kernel Configuration
+# Linux/x86 5.3.12-arch1 Kernel Configuration
#
#
@@ -441,6 +441,9 @@ CONFIG_ARCH_USES_PG_UNCACHED=y
CONFIG_ARCH_RANDOM=y
CONFIG_X86_SMAP=y
CONFIG_X86_INTEL_UMIP=y
+# CONFIG_X86_INTEL_TSX_MODE_OFF is not set
+# CONFIG_X86_INTEL_TSX_MODE_ON is not set
+CONFIG_X86_INTEL_TSX_MODE_AUTO=y
CONFIG_EFI=y
CONFIG_EFI_STUB=y
CONFIG_SECCOMP=y
@@ -9837,7 +9840,7 @@ CONFIG_GCC_PLUGIN_STRUCTLEAK=y
CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF_ALL=y
# CONFIG_GCC_PLUGIN_STRUCTLEAK_VERBOSE is not set
# CONFIG_GCC_PLUGIN_STACKLEAK is not set
-# CONFIG_INIT_ON_ALLOC_DEFAULT_ON is not set
+CONFIG_INIT_ON_ALLOC_DEFAULT_ON=y
# CONFIG_INIT_ON_FREE_DEFAULT_ON is not set
# end of Memory initialization
# end of Kernel hardening options