summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/linux/PKGBUILD10
-rw-r--r--core/linux/config.i4864
-rw-r--r--core/linux/config.i6864
-rw-r--r--core/linux/config.pentium44
4 files changed, 14 insertions, 8 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index f783410f..a5a9473e 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -1,14 +1,14 @@
-# upstream git revision: ecb2b5bb981e565c5049e6075edd51f2207b6e15
+# upstream git revision: 4105c959fe143c5434cfb18ac8df0c5457b94828
source_pentium4=('config.pentium4')
source_i686=('config.i686')
source_i486=('config.i486')
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '623601ed9d7879dd9dba1cd50fc8051f9db508b49b4fc0c47c5a9eb9165fc04e' ]; then
- sha256sums_pentium4=('a6fdd147eb529a9e9aa090b13b7d339605d75d7b12900b8b5f1b895aabc6b05c')
- sha256sums_i686=('a6fdd147eb529a9e9aa090b13b7d339605d75d7b12900b8b5f1b895aabc6b05c')
- sha256sums_i486=('ae13f53ca30b6878b95f82a9bdb6efc6cc2032facbcab52b581896c7ea1cac2d')
+ if [ "${sha256sums[${i}]}" = 'ed60b20ee841e16038da0d145fbf3f53fac94122c4001d6cd03abe64e9e760f6' ]; then
+ sha256sums_pentium4=('887b13d1ef8334f13c4bf94e92a16361dd88bd004df738b066b693fb104634df')
+ sha256sums_i686=('887b13d1ef8334f13c4bf94e92a16361dd88bd004df738b066b693fb104634df')
+ sha256sums_i486=('2897c445c4ad72a00642dbab7cc2b22f916f5b8327eb3fab2246dea3b57296ea')
fi
done
diff --git a/core/linux/config.i486 b/core/linux/config.i486
index d0aad337..3cd288fb 100644
--- a/core/linux/config.i486
+++ b/core/linux/config.i486
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.7.2-arch1 Kernel Configuration
+# Linux/x86 5.7.6-arch1 Kernel Configuration
#
#
@@ -8752,6 +8752,8 @@ CONFIG_HWSPINLOCK=y
#
# Clock Source drivers
#
+CONFIG_TIMER_OF=y
+CONFIG_TIMER_PROBE=y
CONFIG_CLKSRC_I8253=y
CONFIG_CLKEVT_I8253=y
CONFIG_I8253_LOCK=y
diff --git a/core/linux/config.i686 b/core/linux/config.i686
index 22ab7355..33ec2953 100644
--- a/core/linux/config.i686
+++ b/core/linux/config.i686
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.7.2-arch1 Kernel Configuration
+# Linux/x86 5.7.6-arch1 Kernel Configuration
#
#
@@ -8812,6 +8812,8 @@ CONFIG_HWSPINLOCK=y
#
# Clock Source drivers
#
+CONFIG_TIMER_OF=y
+CONFIG_TIMER_PROBE=y
CONFIG_CLKSRC_I8253=y
CONFIG_CLKEVT_I8253=y
CONFIG_I8253_LOCK=y
diff --git a/core/linux/config.pentium4 b/core/linux/config.pentium4
index 22ab7355..33ec2953 100644
--- a/core/linux/config.pentium4
+++ b/core/linux/config.pentium4
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.7.2-arch1 Kernel Configuration
+# Linux/x86 5.7.6-arch1 Kernel Configuration
#
#
@@ -8812,6 +8812,8 @@ CONFIG_HWSPINLOCK=y
#
# Clock Source drivers
#
+CONFIG_TIMER_OF=y
+CONFIG_TIMER_PROBE=y
CONFIG_CLKSRC_I8253=y
CONFIG_CLKEVT_I8253=y
CONFIG_I8253_LOCK=y