summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/linux/PKGBUILD21
1 files changed, 5 insertions, 16 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index 4276e704..343c4f72 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -12,27 +12,16 @@ for ((i=0; i<${#sha256sums[@]}; i++)); do
fi
done
-for _rem_i486_dep in graphviz imagemagick; do
- if printf '%s\n' "${makedepends[@]}" | grep -qxF "${_rem_i486_dep}"; then
- makedepends=(${makedepends[@]/${_rem_i486_dep}/})
- makedepends_i686+=("${_rem_i486_dep}")
- makedepends_pentium4=("${makedepends_i686[@]}")
- fi
-done
-
+# copy architecture specific config file, not default 'config'
eval "$(
- declare -f build | \
- sed '
- s/\bhtmldocs\b//
- '
- declare -f package_linux-docs | \
- sed '
- \@/Documentation/@ s/^\s*rm /\0-f /
- '
declare -f prepare | \
sed '
s,\.\./config,../config.$CARCH,
'
+)"
+
+# patch architecture when copying the kernel Makefile
+eval "$(
declare -f package_linux-headers | \
sed '
\,/tools/objtool" ,d