summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/linux/PKGBUILD10
-rw-r--r--core/linux/config.i4863
-rw-r--r--core/linux/config.i6863
-rw-r--r--core/linux/config.pentium43
4 files changed, 11 insertions, 8 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index 9f4014c8..e4ed2ae2 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -1,14 +1,14 @@
-# upstream git revision: fd161d86c2bca94314e6b7e43c274a3341f8c6cf
+# upstream git revision: da8033e349d4b8bf5e7af6959c4eea9cc9f3d3d8
source_pentium4=('config.pentium4')
source_i686=('config.i686')
source_i486=('config.i486')
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = 'a40c28cca5451478f1bacd5200bdff7e192c2a95685d4fc0b35730aeb29e35f1' ]; then
- sha256sums_pentium4=('90f3618d9960ef485e0a9e87314698a6d78848a04ba795a79da86b41d3cfc09e')
- sha256sums_i686=('90f3618d9960ef485e0a9e87314698a6d78848a04ba795a79da86b41d3cfc09e')
- sha256sums_i486=('d5607830940c37ae2b37634acf8d73100a676bedc410d00f05d371673200f6a2')
+ if [ "${sha256sums[${i}]}" = 'e0d0f140128a8574217701e61e874a0a108f3b8cd0f6e35d8b16afe897999f8e' ]; then
+ sha256sums_pentium4=('ba05b68e347ff0ef44155f3ccddab579ad05fbadf71acaa4455ecd031d7aa32b')
+ sha256sums_i686=('ba05b68e347ff0ef44155f3ccddab579ad05fbadf71acaa4455ecd031d7aa32b')
+ sha256sums_i486=('771ef32ed9733f6ef8952819339f08e9a58856d07fd0c69f0f86b21cd22bd4cc')
fi
done
diff --git a/core/linux/config.i486 b/core/linux/config.i486
index dfbc1f1d..7d491db8 100644
--- a/core/linux/config.i486
+++ b/core/linux/config.i486
@@ -1,6 +1,5 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.2.5-arch1 Kernel Configuration
#
#
@@ -10310,3 +10309,5 @@ CONFIG_DEBUG_BOOT_PARAMS=y
CONFIG_UNWINDER_FRAME_POINTER=y
# CONFIG_UNWINDER_GUESS is not set
# end of Kernel hacking
+CONFIG_AMD_IOMMU_V2=y
+# Linux/x86 5.2.10-arch1 Kernel Configuration
diff --git a/core/linux/config.i686 b/core/linux/config.i686
index feb70437..9cf8fd89 100644
--- a/core/linux/config.i686
+++ b/core/linux/config.i686
@@ -1,6 +1,5 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.2.5-arch1 Kernel Configuration
#
#
@@ -10391,3 +10390,5 @@ CONFIG_DEBUG_BOOT_PARAMS=y
CONFIG_UNWINDER_FRAME_POINTER=y
# CONFIG_UNWINDER_GUESS is not set
# end of Kernel hacking
+CONFIG_AMD_IOMMU_V2=y
+# Linux/x86 5.2.10-arch1 Kernel Configuration
diff --git a/core/linux/config.pentium4 b/core/linux/config.pentium4
index feb70437..9cf8fd89 100644
--- a/core/linux/config.pentium4
+++ b/core/linux/config.pentium4
@@ -1,6 +1,5 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.2.5-arch1 Kernel Configuration
#
#
@@ -10391,3 +10390,5 @@ CONFIG_DEBUG_BOOT_PARAMS=y
CONFIG_UNWINDER_FRAME_POINTER=y
# CONFIG_UNWINDER_GUESS is not set
# end of Kernel hacking
+CONFIG_AMD_IOMMU_V2=y
+# Linux/x86 5.2.10-arch1 Kernel Configuration