summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/coreutils/PKGBUILD7
-rw-r--r--core/coreutils/coreutils-8.30-uname-i486.patch12
2 files changed, 19 insertions, 0 deletions
diff --git a/core/coreutils/PKGBUILD b/core/coreutils/PKGBUILD
new file mode 100644
index 00000000..b44c7b41
--- /dev/null
+++ b/core/coreutils/PKGBUILD
@@ -0,0 +1,7 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # make uname return i486 instead of i686 when used with setarch
+ source+=('coreutils-8.30-uname-i486.patch')
+ md5sums+=('92eefec217ca59608a2e1b9ae7debf64')
+fi
+
diff --git a/core/coreutils/coreutils-8.30-uname-i486.patch b/core/coreutils/coreutils-8.30-uname-i486.patch
new file mode 100644
index 00000000..f7872693
--- /dev/null
+++ b/core/coreutils/coreutils-8.30-uname-i486.patch
@@ -0,0 +1,12 @@
+diff -rauN coreutils-8.30/src/uname.c coreutils-8.30-uname-patch-i486/src/uname.c
+--- coreutils-8.30/src/uname.c 2018-05-14 06:20:24.000000000 +0200
++++ coreutils-8.30-uname-patch-i486/src/uname.c 2019-01-28 21:12:09.151041534 +0100
+@@ -285,6 +285,8 @@
+
+ if (uname (&name) == -1)
+ die (EXIT_FAILURE, errno, _("cannot get system name"));
++
++ strcpy(name.machine, "i486");
+
+ if (toprint & PRINT_KERNEL_NAME)
+ print_element (name.sysname);