summaryrefslogtreecommitdiff
path: root/core/systemd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/systemd/PKGBUILD')
-rw-r--r--core/systemd/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
index 223a7cb8..6b71579b 100644
--- a/core/systemd/PKGBUILD
+++ b/core/systemd/PKGBUILD
@@ -7,12 +7,25 @@ eval "$(
)"
# disabling LTO on i486 in EFI, fails with undefined entry point efi_main
+# => didn't help, disabling gnu-efi now on i486
if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
sed '
/local _meson_options.*/ a \
_meson_options+=(-Db_lto=false)
+ s/-Dgnu-efi=true/-Dgnu-efi=false/
'
)"
fi
+
+# see upstream https://github.com/systemd/systemd/pull/23609 and
+# https://github.com/systemd/systemd/commit/38c87ca2ab96d085158485ecfc46c7cb6af0f166
+source+=('fix-23609-efi-ia32.patch')
+sha512sums+=('1ebcfd699894d62520f9a02a05e966b24e8152b9ab72646e8d0a47212244bd83202bffb4a019f610ace64deaffee24c359d991d08c2e45eae413a55b576b940f')
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -Np1 < ../fix-23609-efi-ia32.patch
+ '
+)"