summaryrefslogtreecommitdiff
path: root/core/syslinux
diff options
context:
space:
mode:
Diffstat (limited to 'core/syslinux')
-rw-r--r--core/syslinux/PKGBUILD13
-rw-r--r--core/syslinux/syslinux-sysmacros.patch11
2 files changed, 24 insertions, 0 deletions
diff --git a/core/syslinux/PKGBUILD b/core/syslinux/PKGBUILD
new file mode 100644
index 00000000..410b180a
--- /dev/null
+++ b/core/syslinux/PKGBUILD
@@ -0,0 +1,13 @@
+# include sysmacros.h in extlinux, otherwise you get undefined references
+# to minor and major
+
+source+=(syslinux-sysmacros.patch)
+sha1sums+=('52c5233da147acd41d542b1673835be966b561e3')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /patch.*efi_no_kbd/a patch -p1 < ../syslinux-sysmacros.patch
+ '
+)"
+
diff --git a/core/syslinux/syslinux-sysmacros.patch b/core/syslinux/syslinux-sysmacros.patch
new file mode 100644
index 00000000..ee7c4b61
--- /dev/null
+++ b/core/syslinux/syslinux-sysmacros.patch
@@ -0,0 +1,11 @@
+diff -rauN syslinux/extlinux/main.c syslinux-sysmacros-patch/extlinux/main.c
+--- syslinux/extlinux/main.c 2018-08-10 11:28:39.164004538 +0200
++++ syslinux-sysmacros-patch/extlinux/main.c 2018-08-10 11:33:05.410671208 +0200
+@@ -19,6 +19,7 @@
+ */
+
+ #define _GNU_SOURCE /* Enable everything */
++#include <sys/sysmacros.h>
+ #include <inttypes.h>
+ /* This is needed to deal with the kernel headers imported into glibc 3.3.3. */
+ #include <alloca.h>