summaryrefslogtreecommitdiff
path: root/core/syslinux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/syslinux/PKGBUILD')
-rw-r--r--core/syslinux/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/core/syslinux/PKGBUILD b/core/syslinux/PKGBUILD
new file mode 100644
index 00000000..410b180a
--- /dev/null
+++ b/core/syslinux/PKGBUILD
@@ -0,0 +1,13 @@
+# include sysmacros.h in extlinux, otherwise you get undefined references
+# to minor and major
+
+source+=(syslinux-sysmacros.patch)
+sha1sums+=('52c5233da147acd41d542b1673835be966b561e3')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /patch.*efi_no_kbd/a patch -p1 < ../syslinux-sysmacros.patch
+ '
+)"
+