summaryrefslogtreecommitdiff
path: root/core/pkgconf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/pkgconf/PKGBUILD')
-rw-r--r--core/pkgconf/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/core/pkgconf/PKGBUILD b/core/pkgconf/PKGBUILD
new file mode 100644
index 00000000..d323fe0c
--- /dev/null
+++ b/core/pkgconf/PKGBUILD
@@ -0,0 +1,17 @@
+# use i686 personality as main personality, no lib32, no 64-bit
+
+source=(${source[@]//x86_64-pc-linux-gnu.personality/})
+sha256sums=(${sha256sums[@]//c8297817ba0b57d003878db247ff34b4c47a7594c9f67dcfe8ff8d6567956cd5/})
+sha256sums[1]='4df633eb84275d51c94bc70a6c56def678ad76dd58573a2ac9b1360732883d96'
+
+eval "$(
+ declare -f package | \
+ sed '
+ /install/s/x86_64-pc-linux-gnu.personality//
+ /ln.*x86_64-pc-linux-gnu-pkg-config/d
+ '
+)"
+
+# temporary fix for download sources
+# (https://bugs.archlinux.org/task/64633)
+source[0]="git+https://git.sr.ht/~kaniini/pkgconf#commit=$_commit"