summaryrefslogtreecommitdiff
path: root/core/pacman
diff options
context:
space:
mode:
Diffstat (limited to 'core/pacman')
-rw-r--r--core/pacman/PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index ce92903a..f75db89a 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -12,14 +12,13 @@ for ((i=0; i<${#sha256sums[@]}; i++)); do
fi
done
-# i486-specific
-if [ "${CARCH}" = "i486" ]; then
+if [ ! "${CARCH}" = "i686" ]; then
# patch architecture where needed
eval "$(
declare -f package | \
sed '
/install.*makepkg.conf/ a \
- sed -i "s@i686@i486@g" "$pkgdir/etc/makepkg.conf"
+ sed -i "s@i686@'"${CARCH}"'@g" "$pkgdir/etc/makepkg.conf"
'
)"
fi