summaryrefslogtreecommitdiff
path: root/core/openssl-1.0
diff options
context:
space:
mode:
Diffstat (limited to 'core/openssl-1.0')
-rw-r--r--core/openssl-1.0/PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/core/openssl-1.0/PKGBUILD b/core/openssl-1.0/PKGBUILD
index 19c81387..bff1d9e0 100644
--- a/core/openssl-1.0/PKGBUILD
+++ b/core/openssl-1.0/PKGBUILD
@@ -1,7 +1,13 @@
+# override openssltarget and optflags for our CARCHs
eval "$(
declare -f build | \
sed '
- s@linux-x86_64@linux-generic32@
- s@ enable-ec_nistp_64_gcc_128 @ @
+ /.*.\/Configure.*/ i \
+ openssltarget=linux-generic32 \
+ if [ "${CARCH}" == 'i686' ]; then \
+ optflags='no-sse2' \
+ elif [ "${CARCH}" == 'i486' ]; then \
+ optflags='386' \
+ fi
'
)"