summaryrefslogtreecommitdiff
path: root/core/nfs-utils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/nfs-utils/PKGBUILD')
-rw-r--r--core/nfs-utils/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/core/nfs-utils/PKGBUILD b/core/nfs-utils/PKGBUILD
new file mode 100644
index 00000000..a8261df5
--- /dev/null
+++ b/core/nfs-utils/PKGBUILD
@@ -0,0 +1,31 @@
+# sprintf format patches: https://marc.info/?l=linux-nfs&m=155854918115682&w=2
+source+=(nfs-utils-2.3.4-nfsdcld-sqlite-PRIx.patch)
+sha1sums+=('4c6c2bc5d188d969b48707366aa7d1b8b255ecc4')
+eval "$(
+ declare -f prepare | \
+ sed '
+ /.*autoreconf.*/i patch -p1 < ../nfs-utils-2.3.4-nfsdcld-sqlite-PRIx.patch
+ '
+)"
+
+# linking errors for statdb_dump test program
+source+=(nfs-utils-2.3.4-testing-statdb_dump-linking.patch)
+sha1sums+=('2d629464292af5a3224173bb8f055d96e00ba68c')
+eval "$(
+ declare -f prepare | \
+ sed '
+ /.*autoreconf.*/i patch -p1 < ../nfs-utils-2.3.4-testing-statdb_dump-linking.patch
+ '
+)"
+
+# -Werror==missing-prototypes aborts 'make check' because 'nlm_sm_prog_3' and
+# 'nlm_sm_prog_4' get no prototypes in 'nlm_sm_inter.h' when generated with 'rpcgen'
+# (could be a bug in 'rpcsvc-proto')\
+source+=(nfs-utils-2.3.4-rpcgen-missing-prototype.patch)
+sha1sums+=('ae1c467933547aa71ff4660c953734d2de69e9e0')
+eval "$(
+ declare -f prepare | \
+ sed '
+ /.*autoreconf.*/i patch -p1 < ../nfs-utils-2.3.4-rpcgen-missing-prototype.patch
+ '
+)"