summaryrefslogtreecommitdiff
path: root/core/linux-olpc-xo1/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/linux-olpc-xo1/PKGBUILD')
-rw-r--r--core/linux-olpc-xo1/PKGBUILD293
1 files changed, 0 insertions, 293 deletions
diff --git a/core/linux-olpc-xo1/PKGBUILD b/core/linux-olpc-xo1/PKGBUILD
deleted file mode 100644
index f7ccf783..00000000
--- a/core/linux-olpc-xo1/PKGBUILD
+++ /dev/null
@@ -1,293 +0,0 @@
-# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-
-MODEL=olpc-xo1
-pkgbase=linux-${MODEL}
-pkgver=5.6.6.arch1
-pkgrel=1
-pkgdesc='Linux for OLPC XO-1'
-_srctag=v${pkgver%.*}-${pkgver##*.}
-url="https://git.archlinux.org/linux.git/log/?h=$_srctag"
-arch=(i486 i686 pentium4 x86_64)
-license=(GPL2)
-makedepends=(
- bc kmod libelf
- xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
- git
-)
-options=('!strip')
-_srcname=archlinux-linux
-source=(
- "$_srcname::git+https://git.archlinux.org/linux.git?signed#tag=$_srctag"
- config # the main kernel config file
- sphinx-workaround.patch
-)
-validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
- '8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
-)
-sha256sums=('SKIP'
- 'dfd3310bc2d3c4adbaba5e4f2260a8a110706993be1c3e02a5ddfe88bf0c63ce'
- '8cb21e0b3411327b627a9dd15b8eb773295a0d2782b1a41b2a8839d1b2f5778c')
-
-export KBUILD_BUILD_HOST=archlinux
-export KBUILD_BUILD_USER=$pkgbase
-export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
-
-prepare() {
- cd $_srcname
-
- echo "Setting version..."
- scripts/setlocalversion --save-scmversion
- echo "-$pkgrel" > localversion.10-pkgrel
- echo "${pkgbase#linux}" > localversion.20-pkgname
-
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = *.patch ]] || continue
- echo "Applying patch $src..."
- patch -Np1 < "../$src"
- done
-
- echo "Setting config..."
- cp ../config .config
- make olddefconfig
-
- make -s kernelrelease > version
- echo "Prepared $pkgbase version $(<version)"
-}
-
-build() {
- cd $_srcname
- make all
- make htmldocs
-}
-
-_package() {
- pkgdesc="The $pkgdesc kernel and modules"
- depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
- replaces=(virtualbox-guest-modules-arch wireguard-arch)
-
- cd $_srcname
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
-
- echo "Installing boot image..."
- # systemd expects to find the kernel here to allow hibernation
- # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
-
- # Used by mkinitcpio to name the kernel
- echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
-
- echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
-
- # remove build and source links
- rm "$modulesdir"/{source,build}
-}
-
-_package-headers() {
- pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
-
- cd $_srcname
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
- echo "Installing build files..."
- install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
- localversion.* version vmlinux
- install -Dt "$builddir/kernel" -m644 kernel/Makefile
- install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
- cp -t "$builddir" -a scripts
-
- # add objtool for external module building and enabled VALIDATION_STACK option
- install -Dt "$builddir/tools/objtool" tools/objtool/objtool
-
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
-
- echo "Installing headers..."
- cp -t "$builddir" -a include
- cp -t "$builddir/arch/x86" -a arch/x86/include
- install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
-
- install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
- install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
-
- # http://bugs.archlinux.org/task/13146
- install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
-
- # http://bugs.archlinux.org/task/20402
- install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
- install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
- install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
-
- echo "Installing KConfig files..."
- find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
-
- echo "Removing unneeded architectures..."
- local arch
- for arch in "$builddir"/arch/*/; do
- [[ $arch = */x86/ ]] && continue
- echo "Removing $(basename "$arch")"
- rm -r "$arch"
- done
-
- echo "Removing documentation..."
- rm -r "$builddir/Documentation"
-
- echo "Removing broken symlinks..."
- find -L "$builddir" -type l -printf 'Removing %P\n' -delete
-
- echo "Removing loose objects..."
- find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
-
- echo "Stripping build tools..."
- local file
- while read -rd '' file; do
- case "$(file -bi "$file")" in
- application/x-sharedlib\;*) # Libraries (.so)
- strip -v $STRIP_SHARED "$file" ;;
- application/x-archive\;*) # Libraries (.a)
- strip -v $STRIP_STATIC "$file" ;;
- application/x-executable\;*) # Binaries
- strip -v $STRIP_BINARIES "$file" ;;
- application/x-pie-executable\;*) # Relocatable binaries
- strip -v $STRIP_SHARED "$file" ;;
- esac
- done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
-
- echo "Adding symlink..."
- mkdir -p "$pkgdir/usr/src"
- ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
-}
-
-_package-docs() {
- pkgdesc="Documentation for the $pkgdesc kernel"
-
- cd $_srcname
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
- echo "Installing documentation..."
- local src dst
- while read -rd '' src; do
- dst="${src#Documentation/}"
- dst="$builddir/Documentation/${dst#output/}"
- install -Dm644 "$src" "$dst"
- done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
-
- echo "Adding symlink..."
- mkdir -p "$pkgdir/usr/share/doc"
- ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
-}
-
-pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
-for _p in "${pkgname[@]}"; do
- eval "package_$_p() {
- $(declare -f "_package${_p#$pkgbase}")
- _package${_p#$pkgbase}
- }"
-done
-
-# vim:set ts=8 sts=2 sw=2 et:
-# upstream git revision: b048babc4fec7ba78bdd0f22e8894aa9b9db7893
-
-source_i486=('config.olpc-xo1')
-sha256sums_i486=('18730a94777487843be91aff97ca7553e6a666219c810fc570a920f877877c1d')
-
-for _rem_i486_dep in graphviz imagemagick; do
- if printf '%s\n' "${makedepends[@]}" | grep -qxF "${_rem_i486_dep}"; then
- makedepends=(${makedepends[@]/${_rem_i486_dep}/})
- makedepends_i686+=("${_rem_i486_dep}")
- makedepends_pentium4=("${makedepends_i686[@]}")
- fi
-done
-
-eval "$(
- if [ "${CARCH}" = 'i486' ]; then
- declare -f build | \
- sed '
- s/\bhtmldocs\b//
- '
- declare -f package_linux-docs | \
- sed '
- \@/Documentation/@ s/^\s*rm /\0-f /
- '
- fi
- declare -f prepare | \
- sed '
- s,\.\./config,../config.$MODEL,
- '
- declare -f package_linux-${MODEL}-headers | \
- sed '
- \,/tools/objtool" ,d
- \,arch/x86/Makefile, {
- a \
- install -t "${builddir}/arch/x86" -m644 arch/x86/Makefile_32.cpu
- }
- '
-)"
-
-# use our tarballer instead of cloning from git
-for ((i=0; i<${#source[@]}; i++)); do
- infos=$(
- printf '%s\n' "${source[${i}]}" | \
- sed -n '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
- T
- p
- '
- )
- if [ -n "${infos}" ]; then
- source[${i}]=$(
- type="${infos%% *}"
- infos="${infos#* }"
- if [ -n "${infos%% *}" ]; then
- prefix="${infos%% *}"
- else
- prefix=''
- fi
- infos="${infos#* }"
- repo="${infos%% *}"
- repo64=$(
- printf '%s' "${repo}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
- infos="${infos#* }"
- if [ "${infos%% *}" = '?signed' ]; then
- key_check=$(
- printf '&valid_keys='
- printf '%s,' "${validpgpkeys[@]}" | \
- sed 's/,$//'
- )
- else
- key_check=''
- fi
- infos="${infos#* }"
- if [ -z "${prefix}" ]; then
- prefix="${repo%.git}"
- prefix="${prefix##*/}"
- fi
- prefix_64=$(
- printf '%s/' "${prefix}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
-
- printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
- "${prefix}" \
- "${pkgver}" \
- "${type}" \
- "${prefix_64}" \
- "${repo64}" \
- "${key_check}" \
- "${infos}"
- )
- fi
-done