summaryrefslogtreecommitdiff
path: root/core/linux-lts/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/linux-lts/PKGBUILD')
-rw-r--r--core/linux-lts/PKGBUILD30
1 files changed, 27 insertions, 3 deletions
diff --git a/core/linux-lts/PKGBUILD b/core/linux-lts/PKGBUILD
index c3e41dd8..becdef5d 100644
--- a/core/linux-lts/PKGBUILD
+++ b/core/linux-lts/PKGBUILD
@@ -1,9 +1,9 @@
-# upstream git revision: a9ffca8ead3309ccffa471695553321845bb0b2d
+# upstream git revision: 248847c71567186d42ca1e4288d1e05a27dd6d38
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '8a42ff42235983b6f9f5e04db072bab6432ee6429312345d40c6cd2a03ea5102' ]; then
- sha256sums[${i}]='9c9b3f4bd5afd6a212a5217dbf243215e788fcacc35cb86522238b39831f2d5a'
+ if [ "${sha256sums[${i}]}" = '6f32ff9e88c4c46e76685839a5376b81b21276e2ca42f1b69a50795afed14f9a' ]; then
+ sha256sums[${i}]='9f78a2f39fdc64a88f3fb09859356eb2a759ee4c3ddd2a630427a8617f95d5e4'
fi
done
@@ -14,3 +14,27 @@ eval "$(
\,arch/x86/Makefile,a install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile_32.cpu
'
)"
+
+# avoid using zstd compression in ultra mode (exhausts virtual memory)
+source+=('no-ultra-zstd.patch')
+sha256sums+=('3997ce6033fdf950a9960f1db720b38c47b1a2e06ab75fc6712c154f596e7c47')
+# upstream prepare() does already do the *.patch patching
+
+# temporarily disabled documentation due to sphinx_rtd_theme (FS32#163)
+pkgname=(
+ $(
+ printf '%s\n' "${pkgname[@]}" | \
+ grep -v '^\$pkgbase-docs'
+ )
+)
+eval "$(
+ declare -f build | \
+ sed '
+ s/\bhtmldocs\b//
+ '
+)"
+makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
+makedepends=(${makedepends[@]//python-sphinx/})
+makedepends=(${makedepends[@]//graphviz/})
+makedepends=(${makedepends[@]//imagemagick/})
+makedepends=(${makedepends[@]//texlive-latexextra/})