summaryrefslogtreecommitdiff
path: root/core/links/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/links/PKGBUILD')
-rw-r--r--core/links/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/core/links/PKGBUILD b/core/links/PKGBUILD
new file mode 100644
index 00000000..5e8edb58
--- /dev/null
+++ b/core/links/PKGBUILD
@@ -0,0 +1,17 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no X11 or graphic libraries
+ makedepends=(${makedepends[@]//libtiff/})
+ makedepends=(${makedepends[@]//libpng/})
+ makedepends=(${makedepends[@]//libxt/})
+ makedepends=(${makedepends[@]//librsvg/})
+
+ # disable xlinks (or rather, compile it the same way as links)
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-graphics --with-x --with-fb/--disable-graphics --without-x --without-fb/
+ '
+ )"
+fi
+