summaryrefslogtreecommitdiff
path: root/core/libsecret/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/libsecret/PKGBUILD')
-rw-r--r--core/libsecret/PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/core/libsecret/PKGBUILD b/core/libsecret/PKGBUILD
index 874dbf43..93d2a9e8 100644
--- a/core/libsecret/PKGBUILD
+++ b/core/libsecret/PKGBUILD
@@ -7,5 +7,13 @@ makedepends_pentium4=("${makedepends_i686[@]}")
if [ "${CARCH}" = "i486" ]; then
# no Gnome (gjs), no dbus-glib
unset check
+
+ # disable Vala (not bootstrapped for i486)
+ eval "$(
+ declare -f build | \
+ sed '
+ s/\(arch-meson $pkgname build\)/\1 -Dvapi=false/
+ '
+ )"
fi