summaryrefslogtreecommitdiff
path: root/core/libaio/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/libaio/PKGBUILD')
-rw-r--r--core/libaio/PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/core/libaio/PKGBUILD b/core/libaio/PKGBUILD
index a4cbd68f..1809af7b 100644
--- a/core/libaio/PKGBUILD
+++ b/core/libaio/PKGBUILD
@@ -11,7 +11,13 @@ eval "$(
# see also FS#60283
source+=('libaio-0.3.111-sizeof-template.patch')
md5sums+=('8c240ea721460fa2d34f9e134b57544d')
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i ../libaio-0.3.111-sizeof-template.patch
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "${srcdir}/${pkgname}-${pkgver}" \
+ patch -Np1 -i ../libaio-0.3.111-sizeof-template.patch
+ '
+)"