summaryrefslogtreecommitdiff
path: root/core/autoconf
diff options
context:
space:
mode:
Diffstat (limited to 'core/autoconf')
-rw-r--r--core/autoconf/PKGBUILD18
-rw-r--r--core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch21
2 files changed, 39 insertions, 0 deletions
diff --git a/core/autoconf/PKGBUILD b/core/autoconf/PKGBUILD
index 1957adf9..320aba12 100644
--- a/core/autoconf/PKGBUILD
+++ b/core/autoconf/PKGBUILD
@@ -6,3 +6,21 @@ if [ "${pkgname}-${pkgver}-${pkgrel}" = autoconf-2.69-4 ]; then
'
)"
fi
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # testing the go macros requires a running go actually
+ checkdepends+=('gcc-go')
+
+ # autoconf: 351 Go: https://lists.gnu.org/archive/html/bug-autoconf/2013-01/msg00000.html,
+ # see FS#57870 (closed upstream)
+ source+=('autoconf-2.69-go-test-351-OpenFile.patch')
+ md5sums+=('a7e1e05d4372b2ef5fae29b59e677e7d')
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /patch -p1.*libtool/ a \
+ patch -Np1 -i "${srcdir}/autoconf-2.69-go-test-351-OpenFile.patch"
+ '
+ )"
+fi
diff --git a/core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch b/core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch
new file mode 100644
index 00000000..b69f423d
--- /dev/null
+++ b/core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch
@@ -0,0 +1,21 @@
+diff -rauN autoconf-2.69/lib/autoconf/go.m4 autoconf-2.69-go-test-351-OpenFile-patch/lib/autoconf/go.m4
+--- autoconf-2.69/lib/autoconf/go.m4 2012-01-21 14:46:39.000000000 +0100
++++ autoconf-2.69-go-test-351-OpenFile-patch/lib/autoconf/go.m4 2018-03-16 16:46:23.323273368 +0100
+@@ -61,7 +61,7 @@
+ # Produce source that performs I/O.
+ m4_define([_AC_LANG_IO_PROGRAM(Go)],
+ [AC_LANG_PROGRAM([import ( "fmt"; "os" )],
+-[f, err := os.Open("conftest.out", os.O_CREATE|os.O_WRONLY, 0777)
++[f, err := os.OpenFile("conftest.out", os.O_CREATE|os.O_WRONLY, 0777)
+ if err != nil {
+ fmt.Println(err)
+ os.Exit(1)
+@@ -107,7 +107,7 @@
+ "os"
+ )
+ ],
+-[f, err := os.Open("conftest.val", os.O_CREATE|os.O_WRONLY, 0777)
++[f, err := os.OpenFile("conftest.val", os.O_CREATE|os.O_WRONLY, 0777)
+ if err != nil {
+ os.Exit(1)
+ }