summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/ksh/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/community/ksh/PKGBUILD b/community/ksh/PKGBUILD
new file mode 100644
index 00000000..5dbc0b05
--- /dev/null
+++ b/community/ksh/PKGBUILD
@@ -0,0 +1,9 @@
+# on i486, uname reports the wrong architecture, so tests fail
+if [ "${CARCH}" = 'i486' ]; then
+ eval "$(
+ declare -f check \
+ | sed '
+ /meson test/ s/$/ || true; ! grep -vwF uname meson-logs/testlog.txt | grep -qwF FAIL
+ '
+ )"
+fi