summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/broadcom-wl-dkms/PKGBUILD2
-rw-r--r--community/eclipse/PKGBUILD2
-rw-r--r--community/freebasic/PKGBUILD4
-rw-r--r--community/mit-scheme/PKGBUILD2
-rw-r--r--community/nvidia-cg-toolkit/PKGBUILD2
-rw-r--r--community/python-iwlib/PKGBUILD2
-rw-r--r--community/teamspeak3-server/PKGBUILD3
-rw-r--r--community/tensorflow/PKGBUILD2
8 files changed, 14 insertions, 5 deletions
diff --git a/community/broadcom-wl-dkms/PKGBUILD b/community/broadcom-wl-dkms/PKGBUILD
index 49b55e6e..f16f641c 100644
--- a/community/broadcom-wl-dkms/PKGBUILD
+++ b/community/broadcom-wl-dkms/PKGBUILD
@@ -1,2 +1,4 @@
source_i686=("https://docs.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35-nodebug-pcoem-${pkgver//./_}.tar.gz")
sha256sums_i686=('4f8b70b293ac8cc5c70e571ad5d1878d0f29d133a46fe7869868d9c19b5058cd')
+source_pentium4=("${source_i686[@]}")
+sha256sums_pentium4=("${sha256sums_i686[@]}")
diff --git a/community/eclipse/PKGBUILD b/community/eclipse/PKGBUILD
index 5da20b19..b6bc2bfd 100644
--- a/community/eclipse/PKGBUILD
+++ b/community/eclipse/PKGBUILD
@@ -7,3 +7,5 @@ sha256sums_i686=('70ae1934385b0b7c25e5a76bfcd6d092bfd8d19ce451c3d909afa3cf244845
'59eb59fd362e4daa0b17bb87a2fbb1019dfb86be1546f398055f491c6303476b'
'09db32c2d958e357b3a959a6860240f3e1eb40f7ffa1815f31661f7f117dd980'
'c7c40966c6cecb719f43487476a52e84f86f680fc34d3be7ae535e03be212b4f')
+source_pentium4=("${source_i686[@]}")
+sha256sums_pentium4=("${sha256sums_i686[@]}")
diff --git a/community/freebasic/PKGBUILD b/community/freebasic/PKGBUILD
index dcfb58df..b368c56c 100644
--- a/community/freebasic/PKGBUILD
+++ b/community/freebasic/PKGBUILD
@@ -1,9 +1,11 @@
source_i686=("http://downloads.sourceforge.net/fbc/FreeBASIC-${pkgver}-linux-x86.tar.xz")
md5sums_i686=('2d0332cc289ec1ba59b017c3a2d4bceb')
+source_pentium4=("${source_i686[@]}")
+md5sums_pentium4=("${md5sums_i686[@]}")
eval "$(
declare -f prepare | \
sed '
- /CARCH/ a [[ "$CARCH" = "i686" ]] && _arch=x86
+ /CARCH/ a [[ "$CARCH" = "i686" ]] && _arch=x86; [[ "$CARCH" = "pentium4" ]] && _arch=x86
'
)"
diff --git a/community/mit-scheme/PKGBUILD b/community/mit-scheme/PKGBUILD
index b36752e4..b09ef334 100644
--- a/community/mit-scheme/PKGBUILD
+++ b/community/mit-scheme/PKGBUILD
@@ -2,3 +2,5 @@ source_i686=("https://ftp.gnu.org/gnu/mit-scheme/stable.pkg/$pkgver/$pkgname-$pk
"https://ftp.gnu.org/gnu/mit-scheme/stable.pkg/$pkgver/$pkgname-$pkgver-i386.tar.gz.sig")
md5sums_i686=('89eb7884c05691ceefad9e7e47aabf5f'
'SKIP')
+source_pentium4=("${source_i686[@]}")
+md5sums_pentium4=("${md5sums_i686[@]}")
diff --git a/community/nvidia-cg-toolkit/PKGBUILD b/community/nvidia-cg-toolkit/PKGBUILD
index b88fdd78..edbe23f6 100644
--- a/community/nvidia-cg-toolkit/PKGBUILD
+++ b/community/nvidia-cg-toolkit/PKGBUILD
@@ -11,3 +11,5 @@ source_i686=(
md5sums_i686=(
'9a9fc5108154808f3b10eafa54df1c74'
)
+source_pentium4=("${source_i686[@]}")
+md5sums_pentium4=("${md5sums_i686[@]}")
diff --git a/community/python-iwlib/PKGBUILD b/community/python-iwlib/PKGBUILD
index 33e85693..d504c3e6 100644
--- a/community/python-iwlib/PKGBUILD
+++ b/community/python-iwlib/PKGBUILD
@@ -3,6 +3,6 @@
eval "$(
declare -f check | \
sed '
- /export PYTHONPATH=/s/x86_64/i686/
+ /export PYTHONPATH=/s/x86_64/${CARCH}/
'
)"
diff --git a/community/teamspeak3-server/PKGBUILD b/community/teamspeak3-server/PKGBUILD
index e54b3d47..08d7c2f0 100644
--- a/community/teamspeak3-server/PKGBUILD
+++ b/community/teamspeak3-server/PKGBUILD
@@ -1,3 +1,2 @@
sha256sums_i686=('d20d1df1d27445c117b47926e70ebd4c62e0338f18aab2c5d2c218ae6c2b0369')
-
-
+sha256sums_pentium4=("${sha256sums_i686[@]}")
diff --git a/community/tensorflow/PKGBUILD b/community/tensorflow/PKGBUILD
index bfd09f66..61820fe9 100644
--- a/community/tensorflow/PKGBUILD
+++ b/community/tensorflow/PKGBUILD
@@ -1,7 +1,7 @@
eval "$(
declare -f prepare | \
sed '
- s|export CC_OPT_FLAGS="-march=x86-64"|export CC_OPT_FLAGS="-march=i686"|
+ s|export CC_OPT_FLAGS="-march=x86-64"|export CC_OPT_FLAGS="-march=${CARCH}"|
'
)"