summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/blender/PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/community/blender/PKGBUILD b/community/blender/PKGBUILD
index 35b2c970..868be908 100644
--- a/community/blender/PKGBUILD
+++ b/community/blender/PKGBUILD
@@ -4,7 +4,7 @@ makedepends=(
depends=(
${depends[@]/openimagedenoise/}
)
-pkgdesc+=", without nonfree CUDA support"
+pkgdesc+=", without CUDA support"
eval "$(
declare -f build \
| sed '
@@ -21,3 +21,12 @@ if [ "${CARCH}" = 'i686' ]; then
'
)"
fi
+
+# no Nvidia Optix
+pkgdesc+=", without Optix support"
+eval "$(
+ declare -f build \
+ | sed '
+ /^\s*cmake / s/;$/ -DWITH_CYCLES_DEVICE_OPTIX=OFF/
+ '
+)"