summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/percona-server/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/community/percona-server/PKGBUILD b/community/percona-server/PKGBUILD
index 43528729..338fb46f 100644
--- a/community/percona-server/PKGBUILD
+++ b/community/percona-server/PKGBUILD
@@ -7,3 +7,20 @@ eval "$(
$ i patch -p1 -i "$srcdir/LF_PINS-size.patch"
'
)"
+
+# disable maintainer mode (-Werror)
+eval "$(
+ declare -f build | \
+ sed '
+ s/-Wno-dev/-Wno-dev -DMYSQL_MAINTAINER_MODE=OFF/
+ '
+)"
+
+# do not build storage backends which are only available on 64-bit
+eval "$(
+ declare -f build | \
+ sed '
+ s/-DWITH_ROCKSDB=ON/-DWITH_ROCKSDB=OFF/
+ s/-DTOKU_DEBUG_PARANOID=OFF/-DWITH_TOKUDB=OFF/
+ '
+)"