summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/lightdm/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/lightdm/PKGBUILD b/community/lightdm/PKGBUILD
new file mode 100644
index 00000000..774930a4
--- /dev/null
+++ b/community/lightdm/PKGBUILD
@@ -0,0 +1,13 @@
+# use polkit-duktape instead of polkit on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//polkit/})
+ makedepends+=(polkit-duktape)
+ if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f package_lightdm | \
+ sed '
+ /depends/s/polkit/polkit-duktape/
+ '
+ )"
+ fi
+fi