summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/xaos/PKGBUILD8
-rw-r--r--community/xaos/xaos.patch22
2 files changed, 30 insertions, 0 deletions
diff --git a/community/xaos/PKGBUILD b/community/xaos/PKGBUILD
new file mode 100644
index 00000000..d3dd57f2
--- /dev/null
+++ b/community/xaos/PKGBUILD
@@ -0,0 +1,8 @@
+source+=('xaos.patch')
+sha256sums+=('b07cdc88be38a30a40bccc2f999bff50ae8a25fc10ed4f2f7c7e2ff117f085e5')
+
+prepare() {
+ patch -p1 -N -i "$srcdir/xaos.patch" -d "$srcdir/$pkgname-$pkgver"
+ gendesk -f -n --pkgname=$pkgname --pkgdesc="$pkgdesc" \
+ --categories='Application;Graphics'
+}
diff --git a/community/xaos/xaos.patch b/community/xaos/xaos.patch
new file mode 100644
index 00000000..7f29f57a
--- /dev/null
+++ b/community/xaos/xaos.patch
@@ -0,0 +1,22 @@
+diff --unified --recursive --text xaos-3.6.orig/src/engine/zoom.c xaos-3.6.new/src/engine/zoom.c
+--- xaos-3.6.orig/src/engine/zoom.c 2013-11-01 08:54:21.000000000 +0100
++++ xaos-3.6.new/src/engine/zoom.c 2019-11-03 12:19:31.569988390 +0100
+@@ -933,6 +933,7 @@
+ }
+
+ #ifndef USE_i386ASM
++REGISTERS(0)
+ static /*INLINE */ void
+ moveoldpoints(void /*@unused@ */ *data1,
+ struct taskinfo /*@unused@ */ *task,
+diff --unified --recursive --text xaos-3.6.orig/src/engine/zoomd.c xaos-3.6.new/src/engine/zoomd.c
+--- xaos-3.6.orig/src/engine/zoomd.c 2013-11-01 08:54:21.000000000 +0100
++++ xaos-3.6.new/src/engine/zoomd.c 2019-11-03 12:19:39.910033088 +0100
+@@ -280,6 +280,7 @@
+ #endif
+ #undef bpp1
+
++REGISTERS(0)
+ static INLINE void fillline(int line)
+ {
+ register unsigned char *RESTRICT vbuff = cimage.currlines[line];